• JXC0917
    0
    Recently I've had an issue where during a game my keyboard will randomly disconnect from the PC. It usually happens while I'm walking forward. The keyboard will turn off and I'll be stuck walking forward as if the key is being held down. I can still use the mouse when this happens. And I can use the controller but I can't stop my character from walking forward while this happens. The computer shows a message when it happens saying the device isn't recognized and shuts it off. Then all the lights on the keyboard go off. But my character is still stuck moving forward. To fix this, I have to unplug everything from the PC, plug it back in, go back into the keymander software, click ready to play, go into play mode, and rapidly press the W key until my character stops moving. Then I have full functionality again. This usually lasts between 30 seconds to 5 minutes before it will drop again. It also only happens while a key is actually being pressed. If I'm just sitting in a menu screen it won't shut off. But if I'm in a game where I'm entering a lot of inputs, that's when it drops.

    I've tried updating the firmware, completely uninstalling and reinstalling the keymander software, resetting the keymander, plugging in a power cord directly to the wall, and using a different controller. The only thing I haven't tried is a new keyboard, but I think the keyboard is fine because it works when I'm just using it on my PC.

    My setup is this:
    Mini USB from game port to rear Xbox One USB
    Mini USB from PC port to PC usb
    Xbox Elite Controller cable from gamepad port to Xbox One controller (confirmed to be the right kind of cord, not just a charge cable)
    Mini USB from power port to wall outlet
    Keyboard and Mouse plugged into USB ports on the PC

    Also worth noting that the keymander, keyboard, and mouse are all plugged into a USB hub that connects to a single USB port on the PC since I only have 2 ports. But I've been playing like that since I got the keymander months ago and this just started happening 2 weeks ago.
  • Moderator [Derek]
    154

    Hi JXC0917,
    We have a handful of users with the same symptoms and our engineers are working on diagnosing the issue. I need to gather some data to help narrow it down:
    Our engineers are asking for us for the following info:
    1. Connection: yours is Console and PC connected with Power port connected to a USB wall charger?
    2. Does your KeyMander have the 3.5mm Data port or not?
    3. KeyMander software version running on your PC?
    4. KeyMander firmware version running on the device?
    5. What game(s) is/are affected?
    6. Console is Xbox One X, S or original? Controller is the original Elite or the new gen 2 Elite? Batteries in the controller or not?
    7. Keyboard make/model?
    8. Mouse make/model?
    9. If PC connected, what PC, OS and anti-virus software are you running?
    10. Were you using Play Mode or Simulation Mode, or does it happen in both?

    Is your USB hub 2.0 or 3.0?

    In the meantime, have you tried connecting the keyboard and mouse directly to the KeyMander?
  • JXC0917
    0
    1. Yes. Console is connected to game port, PC is connected to PC port, Power is connected to a USB wall charger.
    2. My keymander does have the 3.5mm data port.
    3. Keymander software version 1.3.122
    4. Firmware version 1.3.123.002
    5. So far it's any shooter game. Apex, Halo MCC, any Battlefield game. Those are the only games I use the keymander for. I haven't found any games that it doesn't affect that I play with keymander.
    6. Console is Xbox One X. The controller is a regular Xbox controller, and I also tried with another regular xbox controller. Can't test with the elite because my friend is borrowing it. I just use the elite cable to connect the controller. It does it with or without batteries.
    7. I got the keymander + KB/M bundle so it's the HVER Kaliber Gaming Keyboard and Retikal mouse.
    8. See 7.
    9. It's a Lenovo Ideapad Yoga 13 running Windows 10. I just use whatever windows defender software came with the PC.
    10. I was using play mode. I'm actually not really sure what simulation mode is for so I haven't used it.

    It's USB 3.0.

    I haven't tried connecting directly to the keymander. I thought if I did that, I wouldn't be able to use them on the PC. I like the ability to switch back and forth between PC and console with a button push. If I can plug into the keymander and still just use this one keyboard and mouse for console and PC, I'll try it.
  • Moderator [Derek]
    154

    You are correct that connecting the mouse and keyboard directly to the KeyMander will not allow you to share them with the PC. I am trying to find out if you have the same problem by eliminating the PC Play Mode as a potential conflict. I was thinking it may be a software conflict and removing the PC would confirm it. Our engineers are actively troubleshooting this right now as we have a few users with very similar issues.
  • JXC0917
    0
    Well I plugged them both directly to the keymander and the problem did go away. That makes sense since the keyboard was becomming unrecognized to the PC and the keymander wasn't. So unplugging the keyboard from the PC and plugging into the keymander makes sense. I guess I'll play like this in the meantime. Is there a way I can get notified of any software updates that might fix the issue? Will they be posted on this forum?
  • Moderator [Derek]
    154

    Yes, any time that we release a software/firmware update we pin it to the top of every forum so you can't miss it.
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment